Back to overview
Degraded

Slow page loads and time outs

Jul 15 at 02:22pm EDT
Affected services
ControlShift Platform (US datacenter)

Resolved
Jul 15 at 02:40pm EDT

We found that the issue was caused by a denial-of-service attack on one of our customers' site. We've taken measures to block the offending traffic and the platform is now back online and fully restored.

Created
Jul 15 at 02:22pm EDT

We're currently investigating a problem on the platform causing slow page loads and time outs.