Heavy Load
Incident Report for ChangeSprout, Inc
Resolved
The app has recovered and response times have normalized.

Our infrastructure is set to auto-scale in response to traffic spikes, but we weren't able to scale up as quickly as we'd have liked for the traffic spike that preceded this incident. We're adjusting our configuration so we can respond more nimbly to sudden large spikes in traffic.
Posted Apr 15, 2020 - 21:49 UTC
Investigating
We're investigating reports of heavy load on platform pages.
Posted Apr 15, 2020 - 20:49 UTC
This incident affected: ControlShift Platform (US datacenter).