Back to overview
Resolved

Brief platform downtime

Jul 8, 2026 at 11:24pm UTC
Affected services
ControlShift Platform (US datacenter)

Resolved
Jul 8, 2026 at 11:46pm UTC

We identified the cause of the downtime as a massive spike of malicious traffic targeting one of our customer sites. The minutes of downtime occurred as we scaled up our servers to respond to the increased traffic. We've enabled additional protections to mitigate the attack and are continuing to monitor platform traffic.

Created
Jul 8, 2026 at 11:24pm UTC

We observed a few minutes of downtime affecting various customer sites. Service appears to have recovered, and we are currently investigating the root cause.

We will provide further updates as our investigation progresses. If you experience any issues, please contact support@controlshiftlabs.com.