Back to overview
Degraded

Delays on emails and other features

Dec 04 at 05:12am EST
Affected services
ControlShift Platform (US datacenter)

Resolved
Dec 04 at 07:06am EST

We have caught up with background processes, so emails and other processes run in the background should not experience any further delays.
We will continue monitoring this to make sure that the incident doesn't recur.

Created
Dec 04 at 05:12am EST

We're currently experiencing delays on sending emails and processing other tasks on the background. Our engineering team is investigating the source of this issue to fix as soon as possible.