Back to overview
Degraded

Delays on emails and other features

Oct 20 at 09:50am EDT
Affected services
ControlShift Platform (US datacenter)

Resolved
Oct 20 at 11:26am EDT

Our servers running background tasks have successfully processed the jobs queue and are currently operating without delays.
The upstream issue at AWS is still unresolved, so we'll continue monitoring if there are any further impacts on the platform.

Created
Oct 20 at 09:50am EDT

Due to an ongoing incident at AWS, our infrastructure provider, we're currently experiencing delays on sending emails and processing other tasks on the background.

We will continue monitoring the situation and post updates on this and any other effects that the upstream issue on AWS may cause on the platform.