Back to overview
Downtime
Slow Page Loads
Apr 14 at 08:21pm EDT
Affected services
ControlShift Platform (US datacenter)
Resolved
Apr 14 at 08:49pm EDT
We're recovering but continuing to monitor traffic. We'll be performing a full post-mortem to ensure that similar traffic spikes don't cause outages in the future.
Affected services
ControlShift Platform (US datacenter)
Updated
Apr 14 at 08:31pm EDT
We're working to mitigate the platform outage. More updates to follow.
Affected services
ControlShift Platform (US datacenter)
Created
Apr 14 at 08:21pm EDT
We're investigating reports of slow page loads. Updates to follow.
Affected services
ControlShift Platform (US datacenter)