Back to overview
Downtime
Certificate issues
Jan 31 at 09:48am EST
Affected services
ControlShift Platform (US datacenter)
Resolved
Jan 31 at 10:03am EST
We've restored the previous certificate, and sites are back online. We're working to ensure the problem does not recur.
Affected services
ControlShift Platform (US datacenter)
Created
Jan 31 at 09:48am EST
Some customer sites are currently unreachable due to a problem with the HTTPS certificate. We are actively working to resolve the problem.
Affected services
ControlShift Platform (US datacenter)