Back to overview
Degraded

Background jobs are delayed

Jan 08 at 09:32am EST
Affected services
ControlShift Platform (US datacenter)

Resolved
Jan 08 at 01:05pm EST

The backlog has cleared, and background jobs should now be finishing in a timely fashion. We're continuing to work on performance improvements to prevent this from happening again.

Updated
Jan 08 at 12:39pm EST

We're continuing to monitor the background jobs queue. A large portion of the backlog has cleared, and we expect the situation to fully resolve within the next hour or so.

Updated
Jan 08 at 11:40am EST

We have scaled up resources to meet the demand, and we are also working on performance improvements to address the problem. Background jobs are still delayed by up to several hours, but we do expect the situation to improve within the next couple of hours.

Created
Jan 08 at 09:32am EST

Due to heavy load, background jobs are currently delayed by up to 3 hours. We're working on adjusting capacity to address the problem. The jobs will finish eventually, and no data has been lost. Thank you for your patience.