Back to overview
Degraded

Scattered timeouts on customer sites

Jul 15 at 02:57pm EDT
Affected services
ControlShift Platform (US datacenter)

Resolved
Jul 15 at 03:57pm EDT

[Update] We've implemented additional protections to mitigate the DDoS attack. We're continuing to monitor the situation. Page load speeds remain stable for the majority of customers.

Updated
Jul 15 at 03:21pm EDT

[Update] We're continuing to respond to an evolving DDoS attack. Page loads speeds have recovered for the majority of customers. We're continuing to monitor the situation.

Created
Jul 15 at 02:57pm EDT

We're seeing scattered timeouts as we continue to mitigate a denial-of-service attack. We'll post updates soon.