Back to overview
Downtime

US Platform is down

Jul 15 at 12:42pm EDT
Affected services
ControlShift Platform (US datacenter)

Resolved
Jul 15 at 01:10pm EDT

The platform has returned to normal, and pages should be loading in a normal amount of time. We apologize for the inconvenience.

Updated
Jul 15 at 01:05pm EDT

We've identified the cause of the outage as a DDoS attack on one of our customers. We've taken steps to block the attack, and the platform appears to be recovering.

Created
Jul 15 at 12:42pm EDT

We've received reports that requests to the US platform are timing out. We're investigating now.