Back to overview
Degraded

Error pages on US sites

Apr 10 at 10:40am EDT
Affected services
ControlShift Platform (US datacenter)

Resolved
Apr 10 at 10:51am EDT

The errors were caused by an issue with an infrastructure upgrade. The upgrade has finished, and everything should be back to normal.

Created
Apr 10 at 10:40am EDT

Some users are experiencing errors when attempting to view petition pages hosted in our US datacenter. We're aware of the problem and expect it to be resolved soon.