Back to overview
Downtime

Outage in the US datacenter

Apr 01 at 10:22am EDT
Affected services
ControlShift Platform (US datacenter)

Resolved
Apr 01 at 11:04am EDT

The issue has been resolved, and page load times should be back to normal.

The root cause was a denial-of-service attack on one of our customers, taking advantage of inadequate rate limiting on a particular endpoint. We've fixed the rate limiting to prevent this from happening again, and we apologize for the inconvenience.

Updated
Apr 01 at 10:49am EDT

We have tentatively identified the problem and are implementing measures to mitigate it. Sites are coming back online.

Created
Apr 01 at 10:22am EDT

We're investigating reports of timeouts when attempting to access sites hosted in our US datacenter.