Back to overview
Degraded

Slow Page Loads

Mar 06 at 05:27pm EST
Affected services
ControlShift Platform (US datacenter)

Resolved
Mar 06 at 05:39pm EST

We've identified the likely root cause of the issue. A performance issue related to calculating certain statistics coincided with a large data migration, causing unusual load on the database. We've paused the data migration and are working on a plan to mitigate the performance issue so this does not happen again.

Updated
Mar 06 at 05:37pm EST

Page load times have returned to normal. We're continuing our investigation and monitoring.

Created
Mar 06 at 05:27pm EST

We're seeing slow page loads on customer sites. We're investigating now and will update shortly.