Back to overview
Degraded

Slow responses and timeouts in the EU

Feb 23 at 09:23am EST
Affected services
ControlShift Platform (EU datacenter)

Resolved
Feb 23 at 11:25am EST

We've traced the root cause of the issue to a brief network glitch in AWS. We don't expect it to happen again.

Updated
Feb 23 at 09:31am EST

The problem appears to have resolved, and page load times should be back to normal. We're continuing to investigate the root cause of this issue.

Created
Feb 23 at 09:23am EST

We're investigating reports of timeouts and slow page loads for sites hosted in the EU datacenter.