Heavy Load on Customer Sites
Incident Report for ChangeSprout, Inc
Resolved
An unusual traffic pattern caused a period of platform instability.

We've restored service and are investigating long term performance improvements so the issue does not recur in the future.
Posted Apr 06, 2021 - 18:10 UTC
Investigating
We're investigating reports of heavy load on customer sites. More updates to follow.
Posted Apr 06, 2021 - 17:54 UTC
This incident affected: ControlShift Platform (US datacenter).