Delayed Email Delivery
Incident Report for ChangeSprout, Inc
Resolved
We've resolved this issue and email delivery is returning to normal.
Posted Oct 30, 2020 - 15:27 UTC
Investigating
We're experiencing delayed email delivery after a configuration change, and are investigating the root cause.
Posted Oct 30, 2020 - 15:18 UTC
This incident affected: ControlShift Platform (US datacenter).