Heavy Load on Customer Sites
Incident Report for ChangeSprout, Inc
Resolved
We've increased our capacity and service has returned to normal. We'll continue to monitor the platform's performance.
Posted May 14, 2021 - 21:41 UTC
Investigating
We're investing reports of heavy load on customer sites. More updates to follow.
Posted May 14, 2021 - 21:32 UTC
This incident affected: ControlShift Platform (US datacenter).